股票入门基础知识

您所在地位置:首页> 选股公式 > 东方财富公式 > 东方财富选股公式_超前MACD指标公式

东方财富选股公式_超前MACD指标公式

软件类型:选股公式
下载次数:19
浏览次数:312
文件大小:9K
解压密码:www.88xhai.com
更新时间:2019-06-29 12:41:01
分享到:

说明

{www.88xhai.com - 股票入门基础知识_88学海池,股票指标公式分享}
A1:=DATE <= 1070615;
A2:=(100 * (CLOSE - (MA(CLOSE,30)))) / (MA(CLOSE,30));
A3:=100 - ((90 * ((HHV(HIGH,20)) - CLOSE)) / ((HHV(HIGH,20)) - (LLV(LOW,20))));
A4:=100 - (MA(((100 * ((HHV(HIGH,6)) - CLOSE)) / ((HHV(HIGH,6)) - (LLV(LOW,6)))),28));
A5:=MA(A4,6);
A6:=(3 * (SMA((((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100),5,1))) - (2 * (SMA((SMA((((CLOSE - (LLV(LOW,27))) / ((HHV(HIGH,27)) - (LLV(LOW,27)))) * 100),5,1)),3,1)));
A7:=(10);
A8:=(REF(CLOSE,1)) / CLOSE;
A9:=MIN((MA(((AMOUNT / VOL) / 100),15)),(EMA(((AMOUNT / VOL) / 100),15)));
A10:=((1 - ((SMA(((LOW * A8) - (A8 / 10)),6,1)) / (EMA(((AMOUNT / VOL) / 100),15)))) * 100) - (100 / 10);
A11:=((((1 - ((MA((LOW - (A8 / 10)),6)) / A9)) * (DMA(CLOSE,(VOL / CAPITAL)))) / (MA(LOW,6))) * 100) - (100 / 10);
A12:=((((A10 + (A11 / 10)) > 0) AND (DATE > 1000101)) AND (DATE < 1991231)) AND ((COUNT((((1 - (CLOSE / (REF(CLOSE,1)))) > 0.099) AND ((1 - ((REF(CLOSE,1)) / (REF(CLOSE,2)))) > 0.099)),20)) < 3);
A13:=(((((((A10 + (A11 / 10)) > -3.688) AND (DATE > 1000101)) AND (DATE < 1991231)) AND ((CLOSE / (REF(CLOSE,1))) > 1.02)) AND ((COUNT((((1 - (CLOSE / (REF(CLOSE,1)))) > 0.099) AND ((1 - ((REF(CLOSE,1)) / (REF(CLOSE,2)))) > 0.099)),20)) < 3)) AND (((REF(CLOSE,1)) / (REF(CLOSE,2))) < 0.95)) AND ((CLOSE / (HHV(HIGH,20))) < 0.855);
A14:=EMA(CLOSE,8);
A15:=EMA(A14,20);
A16:=CROSS(A14,A15);
A17:=A14 < (EMA(CLOSE,120));
A18:=SUM((IF((CLOSE > (REF(CLOSE,1))),VOL,(IF((CLOSE < (REF(CLOSE,1))),(0 - VOL),0)))),0);
A19:=SUMBARS(VOL,CAPITAL);
A20:=(IF((CLOSE > (LLV(CLOSE,A19))),1,-1)) * (IF((A18 > (LLV(A18,A19))),1,-1));
A21:=IF((A20 = -1),1,0);
A22:=(COUNT((A21 = 1),8)) > 2;
A23:=((SUM(AMOUNT,13)) / ((AMOUNT / VOL) / 100)) / 100;
A24:=DMA((((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7),(VOL / A23));
A25:=(((CLOSE - A24) / A24) * 100) < -15;
A26:=((CLOSE - (MIN(((REF(CLOSE,5)) * 0.865),((REF(CLOSE,21)) * 0.772)))) / CLOSE) < 0.05;
A27:=REF(LOW,1);
A28:=((SMA(ABS((LOW - A27)),3,1)) / (SMA((MAX((LOW - A27),0)),3,1))) * 100;
A29:=EMA((IF((CLOSE * 1.2),(A28 * 10),(A28 / 10))),3);
A30:=LLV(LOW,38);
A31:=HHV(A29,38);
A32:=IF((LLV(LOW,90)),1,0);
A33:=((EMA((IF((LOW <= A30),((A29 + (A31 * 2)) / 2),0)),3)) / 618) * A32;
SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLOR00FFFF,LINETHICK1;
DEA:EMA(DIFF,7),COLORFF33FF,LINETHICK1;
MACD: (DIFF-DEA)*2,COLORSTICK;
{蓝}
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,8,0 ),COLOR333300;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,7,0 ),COLOR444400;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,6,0 ),COLOR555500;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,5,0 ),COLOR777700;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR999900;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLORBBBB00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLORDDDD00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLORFFFF00;
{红}
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,8 ,0 ),COLOR000033;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,7 ,0 ),COLOR000044;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,6 ,0 ),COLOR000055;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,5 ,0 ),COLOR000077;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR000099;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3 ,0 ),COLOR0000BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2 ,0 ),COLOR0000DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1 ,0 ),COLOR0000FF;
{紫}
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,8,0 ),COLOR330033;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,7,0 ),COLOR440044;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,6,0 ),COLOR550055;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,5,0 ),COLOR770077;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLOR990099;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLORBB00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORDD00DD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFF00FF;
{绿}
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,8,0 ),COLOR003300;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,7,0 ),COLOR004400;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,6,0 ),COLOR005500;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,5,0 ),COLOR007700;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLOR009900;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLOR00BB00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLOR00DD00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLOR00FF00;

STICKLINE(A33,0,A33,8,0) ,COLOR001111;
STICKLINE(A33,0,A33,7,0) ,COLOR003333;
STICKLINE(A33,0,A33,6,0) ,COLOR005555;
STICKLINE(A33,0,A33,5,0) ,COLOR007777;
STICKLINE(A33,0,A33,4,0) ,COLOR009999;
STICKLINE(A33,0,A33,3,0) ,COLOR00BBBB;
STICKLINE(A33,0,A33,2,0) ,COLOR00DDDD;
STICKLINE(A33,0,A33,1,0) ,COLOR00FFFF;
MAMACD:=MA(MACD,3);
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,8, 0),color111111;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,7, 0),color333333;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,6, 0),color555555;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,5, 0),color777777;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,4, 0),color999999;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,3, 0),colorbbbbbb;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,2, 0),colordddddd;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD ,1, 0),colorffffff;

STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 8, 0),color1111ff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 7, 0),color3333ff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 6, 0),color5555ff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 5, 0),color7777ff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 4, 0),color9999ff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 3, 0),colorbbbbff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 2, 0),colorddddff;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD , 1, 0),colorffffff;

IF(DIFF<0,DIFF,0),COLORFF00FF,LINETHICK1;
IF(DIFF<0,0,DIFF),COLOR0000FF,LINETHICK1;
IF(DIFF<DEA,DIFF,DEA),COLOR00FFFF,LINETHICK1;
IF(DIFF>DEA,DEA,DEA),COLOR00FF00,LINETHICK1;
DRAWTEXT(CROSS(DIFF,DEA),DIFF,' 建仓'),COLOR00FFFF;
DRAWICON(CROSS(DIFF,DEA),DIFF,9);
DRAWTEXT(CROSS(DEA,DIFF),DEA,' 清仓'),COLOR00FF00;
DRAWICON(CROSS(DEA,DIFF),DEA,15);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(DX,13);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,1),LOW*0,'  买'),COLORRED;
DRAWICON(FILTER(买=1,1),LOW*0,17);
RSI:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(85,RSI),HIGH*0,12);

DRAWTEXT(CROSS(85,RSI),HIGH*0,' 卖'),COLORYELLOW;


免责声明:本站不推荐任何股票,不收会员,站内的广告不代表88股海的观点,目的在于传播更多信息,由此引起的一切法律责任均与本网无关,专注为中小股民提供炒股入门知识,股票入门基础知识,股票资讯,今日股市新闻,股票行情等信息,88学海池—专业的股票学习网站!股市有风险 投资需谨慎。